[zeromq-dev] [otish] "Why ZeroMQ"

Matt Weinstein matt_weinstein at yahoo.com
Tue Jul 27 15:50:52 CEST 2010


That's why I program in APL, but I digress :-)

This is a Pattern Language problem.  Whereas Pub and Sub are  
relatively well know terms, In and Out are relative and confusing.

What we need is an operational (as opposed to denotational) term to  
describe these, as most people don't see anything different about each  
end of a physical pipe.  Something like Push and Pop, Write and Read,  
etc.

Some that come to mind:

	Fill and Drain
	Entry and Exit

More queue like:
	Front and Back
	
etc.

I like
	ZMQ_PIPE_ENTRY and ZMQ_PIPE_EXIT

or similar, I'm sure a plumber would differ :-)

On Jul 27, 2010, at 9:42 AM, Pieter Hintjens wrote:

> On Tue, Jul 27, 2010 at 3:40 PM, Matt Weinstein
> <matt_weinstein at yahoo.com> wrote:
>> PIN and POUT are shorter :-)
>
> Or just PI and PO.  Reminds me of a guy who defended 1-letter variable
> names with "but they take less time to type".
>
> The point of names is to express something to the reader.  The
> programmer is doing copy/paste of code fragments the whole time
> anyhow.
>
> -Pieter
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev




More information about the zeromq-dev mailing list