[zeromq-dev] "inproc" socket connection fails onCentos5/AmazonEC

Martin Sustrik sustrik at 250bpm.com
Mon Jul 19 08:41:28 CEST 2010


Dmitri Toubelis wrote:
> Martin,
> 
> I tried it already and if I introduce a small delay after binding a socket,
> then everything works as supposed to. However, I bind and then connect
> sockets sequentially from a single thread, so if these calls are synchronous
> they should be executed in a right sequence. Is there any "asynchronicity"
> in socket binding? If so then is there a way to disable it?

There is no asynchronicity fro "inproc" transport. Can you provide the 
code to reproduce the problem?

> I also noticed that socket binding on Centos5 platform sometimes fails too.
> I will try adding another delay after socket creation and before binding but
> this error is more rare and harder to reproduce.
> 
> I also tried it on non-Amazon machine to rule out their custom kernel, but
> result is still the same.

The code for inproc transport is platform-agnostic.

Martin



More information about the zeromq-dev mailing list