[zeromq-dev] Problem in example "A simple client/server application"

Fred Mobach fred at mobach.nl
Sat Feb 27 18:02:32 CET 2010


Hello,

First time user and a problem in testing example "A simple client/server 
application", but the problem is already solved. :-)

Environment :
Linux nnservans 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 
x86_64 x86_64 x86_64 GNU/Linux (openSUSE 11.1)

server.c and client.cpp copied from the webpage Documentation, compiled,
an export LD_LIBRARY_PATH=/usr/local/lib executed and then server and 
client were started. Nothing seemed to happen, so I tried tcpdump -n -i 
lo :
17:08:37.523272 IP 127.0.0.1.55540 > 127.0.0.1.5555: S 
17:08:37.523295 IP 127.0.0.1.5555 > 127.0.0.1.55540: R 0:0(0) ack

That R[eset] seems strange, so I checked with netstat -anp which 
revealed
tcp  0  0 127.0.0.2:5555  0.0.0.0:*   LISTEN  3180/server

Well, that's not going to work. So I changed a line in server.c :
    /* Bind to the TCP transport and port 5555 on the 'lo' interface */
    rc = zmq_bind (s, "tcp://127.0.0.1:5555");
And that's it. Then it runs as intended. But no clue why.

Just one question remains : were can I grab in the server environment 
the IP address and portnumber of the sending client ?
-- 
Fred Mobach - fred at mobach.nl - postmaster at mobach.nl
website : https://fred.mobach.nl
 .... In God we trust ....
 .. The rest we monitor ..



More information about the zeromq-dev mailing list