[zeromq-dev] Cross Compiling and running a Client for the PowerPC

lone squirrely thelonesquirrely at gmail.com
Sat Feb 20 00:05:09 CET 2010


I am doing exactly that!

It would turn out that if i manually edit the platform.hpp to use
malloc i get it to run.  I then had to turn on the uuid libraries and
copy the src files (believe me, not that bad for cross compiling...)
and bam! it finished the builds as i anticipated.

Wrapped it up in a kernel and it fired right up!  There might be a
more elegant way to do this but this would do for now.  For
clarification, I just used the program prompt, I didn't try the
forwarder/queue/etc on the powerpc either.

I was thinking of overriding the 'ac_cv_func_malloc_0_nonnull' var to
be true - it might make the malloc problem vanish.  I am just not sure
what that variable controls.  If you have any questions on how to do
this or what i did - feel free to ask!


Thanks for making this software guys!  It is well done.
:: ryan

On Fri, Feb 19, 2010 at 2:56 PM, Martin Lucina <mato at kotelna.sk> wrote:
> thelonesquirrely at gmail.com said:
>> In trying to configure and compile the zmq library I ran into a small
>> snag.  The configuration goes well with this line:
>>
>> $ ./configure --with-cpp --prefix=<path>/zeromq2/install_powerpc
>> --disable-shared --with-chat CC=powerpc-linux-uclibc-gcc
>> CXX=powerpc-linux-uclibc-g++ --host=powerpc-linux
>
> You are trying to crosscompile to a uClibc host.
>
> I doubt anyone has tried this, and I'm not even sure if uClibc provides all
> the runtime 0MQ requires (pthreads, stdc++).
>
> So you're on your own, unless there's someone on the list who has
> experience with uClibc.
>
> -mato
>



More information about the zeromq-dev mailing list