[zeromq-dev] using autogen.sh

lone squirrely thelonesquirrely at gmail.com
Fri Feb 19 18:26:24 CET 2010


Hey,

I think this is gonna be a dumb question, but I thought I would ask anyways :).

I've never used the autotools (automake, autoconf, auto...), so I am
at a loss.  I run the autogen.sh which should gen the configure script
(right) and then I can work the parameters to that for the building.
yet when I do this I get the following:

% ./autogen.sh
autoreconf: Entering directory `.'
autoreconf: configure.in: not using Gettext
autoreconf: running: aclocal --force -I config
autoreconf: configure.in: tracing
autoreconf: configure.in: not using Libtool
autoreconf: running: /usr/bin/autoconf --include=config --force
configure.in:52: error: possibly undefined macro: AC_LIBTOOL_WIN32_DLL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.in:53: error: possibly undefined macro: AC_PROG_LIBTOOL
autoreconf: /usr/bin/autoconf failed with exit status: 1

Could not run autoreconf, check autotools installation.

I tried adding m4_pattern_allow ([^AC_]) to the configure.in - it
passes that part of autoreconf but the makefiles complain about the
same macros.

What dumb thing am I missing?

:: ry



More information about the zeromq-dev mailing list