[zeromq-dev] zeromq 2.0b2 compile error

Pavol Malosek malosek at fastmq.com
Thu Feb 18 20:48:15 CET 2010


Hello,

For me seems linke uuid-dev package is still not installed.
Yes, I wanted to see if you have libuuid.a installed since should be in libuuid-dev package.
Is there uuid.h file somewhere in the system?

Could you please send your src/platform.hpp file?

malo 

  ----- Original Message ----- 
  From: jonathan morabito 
  To: Pavol Malosek 
  Cc: Vitaly Mayatskikh ; mato at kotelna.sk ; zeromq-dev at lists.zeromq.org 
  Sent: Thursday, February 18, 2010 8:40 PM
  Subject: Re: [zeromq-dev] zeromq 2.0b2 compile error


  Ah!  Thanks!  That was what I was missing!  I created a symlink in /lib64 from "libuuid.so" to "libuuid.so.1", which in turn links to "libuuid.so.1.2"

  Now configure completes successfully.  I now get the following errors on make:

  "uuid.hpp:67: error: field 'uuid' has incomplete type
  uuid.cpp: In constructor 'zmq::uuid_t::uuid_t()':
  uuid.cpp:80: error: 'uuid' was not declared in this scope
  uuid.cpp:80: error: 'uuid_generate' was not declared in this scope
  uuid.cpp:81: error: 'uuid_unparse' was not declared in this scope
  make[2]: *** [libzmq_la-uuid.lo] Error 1"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100218/d5cd7576/attachment.htm>


More information about the zeromq-dev mailing list