[zeromq-dev] zeromq 2.0b2 compile error

Pavol Malosek malosek at fastmq.com
Thu Feb 18 19:19:17 CET 2010


Hello,

your linker could not find libuuid
configure:20725: gcc -o conftest -g -O2 -D_REENTRANT   conftest.c -luuid  -lstdc++ -lpthread  >&5
/usr/bin/ld: cannot find -luuid
collect2: ld returned 1 exit status

have a look at output from
ldconfig -v | grep uuid
should looks like
libuuid.so.1 -> libuuid.so.1.2

you still have to have libuuid.so symlink (pointing to libuuid.so.X) and and libuuid.a file on your linker path. 

you can still add -L<lib dir> into LDFLAGS env var before running configure.

malo
  ----- Original Message ----- 
  From: jonathan morabito 
  To: mato at kotelna.sk 
  Cc: zeromq-dev at lists.zeromq.org 
  Sent: Thursday, February 18, 2010 6:53 PM
  Subject: Re: [zeromq-dev] zeromq 2.0b2 compile error


  It's attached to this message.  Thanks!


  On Thu, Feb 18, 2010 at 12:45 PM, Martin Lucina <mato at kotelna.sk> wrote:

    jonathan.morabito at gmail.com said:
    > Just ran "sudo yum install e2fsprogs-libs", which updated 6 packages
    > successfully.  Still getting the same error... "Could not link with libuuid,
    > install develop version"


    Could you send me the config.log file produced by configure?

    Thanks,

    -mato






------------------------------------------------------------------------------


  _______________________________________________
  zeromq-dev mailing list
  zeromq-dev at lists.zeromq.org
  http://lists.zeromq.org/mailman/listinfo/zeromq-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100218/5791c7dc/attachment.htm>


More information about the zeromq-dev mailing list