[zeromq-dev] zeromq 2.0b2 compile error

jonathan morabito jonathan.morabito at gmail.com
Thu Feb 18 16:55:14 CET 2010


Hello



I am attempting to compile zeromq 2.0 beta 2 from the Github source.
Autogen.sh
works just fine and I make it to “./configure”.  However, I receive the
following error during this operation:



*“configure: error: Could not link with libuuid, install develop version.”*

* *

>From looking through the archives, I found this string of messages, in which
dev Marcin Gozdalik seemed to have the same issue:
http://lists.zeromq.org/pipermail/zeromq-dev/2010-January/001887.html  (I
too had that libtool issue, until I tried using the Git version instead of
the tar.gz linked from the main site…)



Anyway, I am positive that I have uuid and uuid-devel installed, I installed
the CentOS 5 RPM files for both.  (uuid-1.6.1-3.el5.kb.x86_64.rpm &
uuid-devel-1.6.1-3.el5.kb.x86_64.rpm)



For reference, I am running Red Hat Enterprise Linux 5.3 on an x86_64
machine.



Anyone have any idea how to fix this?



Cheers,

Jonathan Morabito
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100218/04b89815/attachment.htm>


More information about the zeromq-dev mailing list