[zeromq-dev] Build problems with trunk on OS X 10.5

Pavol Malosek malosek at fastmq.com
Mon Feb 15 19:54:31 CET 2010


----- Original Message ----- 
From: "Martin Sustrik" <sustrik at fastmq.com>
To: <ellisonbg at gmail.com>
Cc: "Pavol Malosek" <malosek at fastmq.com>; "zeromq-dev" 
<zeromq-dev at lists.zeromq.org>
Sent: Monday, February 15, 2010 7:16 PM
Subject: Re: [zeromq-dev] Build problems with trunk on OS X 10.5


> Brian Granger wrote:
>> Getting closer maybe:
>>
>> $ sudo cp /usr/X11/share/aclocal/pkg.m4 /usr/share/aclocal
>> $ ./autogen.sh
>> $ ./configure --prefix=/usr/local/zeromq2    # This works now!
>> $ make
>
> Nice. I have no idea what's going on here. Is there a way to get this into 
> the standard build?

It was just broken pkg-config installation...

Looking into Makefile.am from pkg-config-0.23
m4dir = $(datadir)/aclocal
m4_DATA = pkg.m4

Looking at configure --help
  --datarootdir=DIR      read-only arch.-independent data root 
[PREFIX/share]
  --datadir=DIR          read-only architecture-independent data 
[DATAROOTDIR]

So when pkg-config is configured with 
./configure --prefix=/usr/local/pkg-config-0.23
then pkg.m4 should finish in /usr/local/pkg-config-0.23/share/aclocal/ where 
aclocal does not search for it.

Anyway nobody ever tried to run ./autogen.sh on OSX - I'm happy that it 
works.

BTW: we need PKG_CHECK_MODULES macro for getting glib configuration (needed 
for OpenPGM)

malo 




More information about the zeromq-dev mailing list