[zeromq-dev] ZMQ during OS reboot

Dannoy Lee dannoy.lee at gmail.com
Mon Dec 6 02:50:54 CET 2010


No,I didn't set socket ID .

On Mon, Dec 6, 2010 at 1:04 AM, Sven Koebnick <Sven.Koebnick at t-online.de>wrote:

> did you set socket ID on both ends? req AND rep?
>
> ^5
> Sven
> ---------------------------------------------------------
> E = mc² ± 2dBA    ----- everything is relative
> ---------------------------------------------------------
>
>
>
> -----Original Message-----
> Date: Sat, 04 Dec 2010 13:59:45 +0100
> Subject: [zeromq-dev] ZMQ during OS reboot
> From: Dannoy Lee <dannoy.lee at gmail.com>
> To: zeromq-dev at lists.zeromq.org
>
> Hi,
>   I have tried ZMQ in my app which use ZMQ to distribute message across
> LAN.The pattern I use is REP-REQ.
>   What confused is that if the REP-end is soft-dead(it means the app
> equiped with ZMQ is down), when I restart it,the REQ-end can talk to REP-end
> very well.But when the PC which the REP-end is running on is down(for
> example, shutting down the power),the REQ-end cannot connect to it after I
> start the PC again.
>    Any hint? Thank you.
>
> --
> Dannoy.Lee love you all.
>
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>
>


-- 
Dannoy.Lee love you all.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20101206/54b6ca86/attachment.htm>


More information about the zeromq-dev mailing list