[zeromq-dev] Problem trying to use zeromq with google protocol buffers over a network

Jon Dyte jon at totient.co.uk
Wed Aug 25 21:23:07 CEST 2010

David Dawson wrote:
> Hi,
> I am trying to create an implementation of zeromq using Google Protocol
> Buffers. I followed the Hello World example and used that as a template for
> a similar version using Google Protocol Buffers. Everything worked fine
> locally, but when I tried it over a network, the server never receives any
> messages. I used a network analyzer and confirmed that messages were indeed
> being received and sent as they should, so I am not sure what is happening.
> Here are the pastebins:
> This is the client application: http://paste.pocoo.org/show/254392/
> This is the server application: http://paste.pocoo.org/show/254393/

as you are using req-rep sockets, then the server side will need to do a 
recv and a send call
and the client side send then recv?

for the REQ-REP sockets the send/recv is synchronous and has to happen 
in lock step fashion.

More information about the zeromq-dev mailing list