[zeromq-dev] Problem trying to use zeromq with google protocol buffers over a network

David Dawson david.dawson at tplogic.com
Wed Aug 25 20:24:30 CEST 2010


I am trying to create an implementation of zeromq using Google Protocol
Buffers. I followed the Hello World example and used that as a template for
a similar version using Google Protocol Buffers. Everything worked fine
locally, but when I tried it over a network, the server never receives any
messages. I used a network analyzer and confirmed that messages were indeed
being received and sent as they should, so I am not sure what is happening.
Here are the pastebins:

This is the client application: http://paste.pocoo.org/show/254392/

This is the server application: http://paste.pocoo.org/show/254393/

Here are further details:

Zeromq version: 2.0.7
Client Computer OS: Windows 7 64-bit
Server Computer OS: Windows XP 32-bit
I used Visual Studio 2008 for developing and compiling.

It's probably something really simple that I am missing. I appreciate the
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20100825/a2e8647d/attachment.htm>

More information about the zeromq-dev mailing list