[zeromq-dev] Polling API

Pieter Hintjens ph at imatix.com
Wed Apr 14 12:09:14 CEST 2010

On Wed, Apr 14, 2010 at 12:06 PM, Martin Sustrik <sustrik at 250bpm.com> wrote:

> I like pollset better, however, some people already created such object in
> individual languages and called them 'poller' IIRC.

> What about _ctl? That matches epoll interface. Also, it's POSIX-y and widely
> familiar.

I personally dislike abbreviations in APIs but this one is widely
used, gets my vote.

>> - '_event' is not a verb, how about '_read' or '_get'?
> Or maybe _wait?

If the call waits, it's perfect :-)


More information about the zeromq-dev mailing list