[zeromq-dev] Polling API

Martin Sustrik sustrik at 250bpm.com
Wed Apr 14 12:06:11 CEST 2010

Pieter Hintjens wrote:

> - 'pollset' is more descriptive than 'poller'

I like pollset better, however, some people already created such object 
in individual languages and called them 'poller' IIRC.

> - '_update' is more descriptive than '_mod' (which says 'moderator' to me :-)

What about _ctl? That matches epoll interface. Also, it's POSIX-y and 
widely familiar.

> - '_event' is not a verb, how about '_read' or '_get'?

Or maybe _wait?


More information about the zeromq-dev mailing list