[zeromq-dev] Using multicast address for java perf tools

Mike Perik michaelperik at yahoo.com
Wed Sep 23 03:42:32 CEST 2009


I'm playing around with the alpha2 release of the v2 software.  I'm trying to use a multicast address with the local_lat and remote_lat java perf examples.

I tried using the 'udp://eth0;224.0.0.1:5555' address from the examples on the http://www.zeromq.org/area:download-v20-alpha2 page.

This is the command line:

java -Djava.library.path=/Users/mikep/tmp/zeromq-2.0-alpha2/bindings/java/.libs -cp ../../bindings/java/Zmq.jar:. local_lat 'udp://eth0;224.0.0.1:5555' 256 5

And the error I get is:

Exception in thread "main" java.lang.Exception: Bad address
at org.zmq.Socket.bind(Native Method)
at local_lat.main(local_lat.java:39)


I also hardcoded the address in the java class but the same error occurred.

I'm trying this on a Mac.

I haven't found any documentation on the format of the address.

What am I doing wrong or does this not work yet?

Mike


      



More information about the zeromq-dev mailing list