[zeromq-dev] is pgm transport working in alpha3?

Yuri Finkelstein yurif2005 at gmail.com
Wed Nov 4 23:26:53 CET 2009


I'm trying to run the perf test using openpgm multicast and can't get it to
work:

machine 1:

 sudo ./perf/cpp/local_thr "udp://eth0;226.0.0.1:5555" 1024 100000

machine 2
 sudo ./perf/cpp/remote_thr "udp://eth0;226.0.0.1:5555" 1024 100000


the remote_thr process exits silently after few seconds.

Some time after that tje local_thr process reports:
** (process:32674): WARNING **: peer expired, tsi
227.186.205.113.22.215.39440


No evidence ot packets sent or received. The same works with TCP as
expected.

I tried pgm:// with the same result.

I do see both processes joining multicast group on their boxes using netstat
-g.

Documentation for 1.0 version says that zmq_server needs to be running in
the background for multicast to work. But in 2.0 alpha there is no such
process needed anymore. Right?


What's wrong here?

Thanks,
Yuri
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20091104/ad188590/attachment.html>


More information about the zeromq-dev mailing list