[zeromq-dev] Java API visibility

Andrews, Ross randrews at ea.com
Wed Jun 10 01:19:55 CEST 2009


Hello Malo,

Just so you know I checked out the trunk and built it. The packaging for the Java has not changed for Windows.

I'm also having an issue of my own. I'm trying to run the example java files mentioned in the early Java examples thread. I believe I have the class and library file referenced properly but I'm getting an error from the j_local_lat.java and J_remote_lat.java files.

Whenever the code 'obj.receive (true).message;' appears I get the errors:
                - The type Zmq$InboundData cannot be resolved. It is indirectly referenced from
                 required .class files
                - The method receive(boolean) from the type Zmq refers to the missing type Zmq
                 $InboundData

I'm not sure where I've gone wrong, any help would be much appreciated.

Thanks in advance,

Ross



From: zeromq-dev-bounces at mail.imatix.com [mailto:zeromq-dev-bounces at mail.imatix.com] On Behalf Of Lucas Amador
Sent: Tuesday, June 09, 2009 11:29 AM
To: Pavol Malosek
Cc: zeromq-dev at mail.imatix.com
Subject: Re: [zeromq-dev] Java API visibility

Great! But yesterday at night i was able to successfuly compile the Zmq class with the org.zmq namespace after modify a couple of c++ files, Makefiles and the java class. Was a nice experience (!) Im using POSIX, btw

There is any plans to implement something better to manage errors than assert? Exceptions? I really don't know if that is possible with JNI

Regards

2009/6/9 Pavol Malosek <malosek at fastmq.com<mailto:malosek at fastmq.com>>
Hello Lucas,

Java packaging has changed since 0.6.1 release. Please check out the trunk.
Zmq class was moved to org.zmq namespace and Zmq.jar file is created.

Please let us know if it works for you.

BTW: Are you using Windows or POSIX?

malo


----- Original Message -----
From: "Lucas Amador" <lucazamador at gmail.com<mailto:lucazamador at gmail.com>>
To: <zeromq-dev at lists.zeromq.org<mailto:zeromq-dev at lists.zeromq.org>>
Sent: Tuesday, June 09, 2009 12:37 AM
Subject: [zeromq-dev] Java API visibility


> Hi, i'm trying to integrate zeromq with a java application but the
> java zeromq class was compiled without package, and since jre 1.3
> isn't possible to import class that belongs to the default package. I
> need to use a zeromq java api in my application but isn't possible
> because of that. Also tried to recompile the libjzmq library adding
> the package declaration to the .java but don't worked for me.
>
> Someone could help me?
>
> Thanks
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org<mailto:zeromq-dev at lists.zeromq.org>
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20090609/21f0956e/attachment.htm>


More information about the zeromq-dev mailing list