[zeromq-dev] python binding error:Function not implemented fd!= -1(ysocketpair.cpp:34)

bawbaw hu bawbaw.hu at gmail.com
Tue Jul 14 00:26:59 CEST 2009


Hi,
It is Ok,I can Run 0MQ 1.0 when i edit ./libzmq/zmq/platform.hpp and comment
out line #define ZMQ_HAVE_EVENTFD 1

Thank you.

bawbaw hu

2009/7/14 Pavol Malosek <malosek at fastmq.com>

>  Hello,
>
> Problem seems to be related to Debian's eglibc switch (I'll investigate it
> more).
>
> Simple workaround is:
> 1. run ./configure --with...
> 2. edit ./libzmq/zmq/platform.hpp and comment out line #define
> ZMQ_HAVE_EVENTFD 1
> 3. make
> ...
>
> malo
>
>
> ----- Original Message -----
>  *From:* bawbaw hu <bawbaw.hu at gmail.com>
> *To:* Pavol Malosek <malosek at fastmq.com> ; zeromq-dev at lists.zeromq.org
> *Sent:* Monday, July 13, 2009 4:44 PM
> *Subject:* Re: [zeromq-dev] python binding error:Function not implemented
> fd!= -1(ysocketpair.cpp:34)
>
> Hi,
>
> $ dpkg -l | grep libc6
>
> ii  libc6                             2.9-12                     GNU C
> Library: Shared libraries
> ii  libc6-dev                         2.9-12                     GNU C
> Library: Development Libraries and Hea
> ii  libc6-i686                        2.9-12                     GNU C
> Library: Shared libraries [i686 optimi
>
> $ cat /etc/debian_version
> squeeze/sid
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.zeromq.org/pipermail/zeromq-dev/attachments/20090714/54d9fc12/attachment.htm>


More information about the zeromq-dev mailing list