[zeromq-dev] python binding error:Function not implemented fd!= -1(ysocketpair.cpp:34)

Pavol Malosek malosek at fastmq.com
Mon Jul 13 16:04:03 CEST 2009


Hello,

Seems like 0MQ is trying to use event_fd as main evening mechanisms. Working 
support for eventd is provided in glibc since version 2.8 while last stable 
Debian (Lenny) has libc6 version 2.7. So epoll should be used instead.

Did you compile 0MQ on the host where you are trying to run it?
If so can you please send us outputs from
$ dpkg -l | grep libc6
$ cat /etc/debian_version
$ uname -a

and config.log file after running configure in zmq-0.6.1 directory.

malo


>----- Original Message ----- 
>From: bawbaw hu
>To: zeromq-dev at lists.zeromq.org
>Sent: Monday, July 13, 2009 1:12 PM
>Subject: Re: [zeromq-dev] python binding error:Function not implemented 
>fd!= -1(ysocketpair.cpp:34)
>
>
>Hi malo,
>
>OS :Debian Linux  2.6.26-1-686
>Python 2.5.4
>0MQ:0.6.1
>starting zmq_serve: nohup zmq_server --port 5300& 




More information about the zeromq-dev mailing list