[zeromq-dev] network problem

Pavol Malosek malosek at fastmq.com
Wed Dec 10 09:55:08 CET 2008


Are you sure with you IP addresses or it is just typo in the email?


----- Original Message ----- 
From: Aamir M
To: zeromq-dev at lists.zeromq.org
Sent: Wednesday, December 10, 2008 4:18 AM
Subject: [zeromq-dev] network problem

SORRY .. I forgot to mention what the error is:

On a machine with IP address , I run the following commands with 
the chat example:

$ zmq_server 5222 &
$ ./chatroom "foo" eth1 eth1

Now from a different machine with IP address, I type:

$ ./display "foo"

It works!  ....

Now I reverse the situation. On, I run the commands:

$ zmq_server 5222 &
$ ./chatroom "foo" eth0 eth0

And from, I run:

$ ./display "foo"

Unfortunately this does not work. It gives the FOLLOWING ERROR:

No route to host
rc != -1 (tcp_socket.cpp:153)

The funny thing is, if I instead type:

$ telnet 5222  I do get a connection. So the host is indeed 
available, but zmq cannot see it for some reason.

zeromq-dev mailing list
zeromq-dev at lists.zeromq.org

More information about the zeromq-dev mailing list