[zeromq-dev] error import after installing pyzmq latest version

Min RK benjaminrk at gmail.com
Sat Dec 29 20:26:52 CET 2012


On Dec 29, 2012, at 1:27, Maxa Jean Aimee <maxajeanaimee at yahoo.fr> wrote:

> Hi everyone,
> I have an error when i attempted to update my zeromq to the new version 3.2
> This is the ouput that I have:
> 
> 
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
>   File "/usr/local/lib/python2.7/dist-packages/zmq/__init__.py", line 51, in <module>
>     from zmq import core, devices
>   File "/usr/local/lib/python2.7/dist-packages/zmq/core/__init__.py", line 26, in <module>
>     from zmq.core import (constants, error, message, context,
> ImportError: /usr/local/lib/python2.7/dist-packages/zmq/core/socket.so: undefined symbol: zmq_sendmsg
> 
> I really don't know what's going on ?
> I'm using ubuntu 12.04 and I develop on python.
> I've already check on stackoverflow website but i did not see anything.
> It works well before but I started to have this error when I've finish  installing   pyzmq 2.2.0.1.
> 
> Could anyone help me on this ?

You need to recompile / reinstall pyzmq when you do a major upgrade of libzmq.

>  
> Thanks
> MAXA
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.zeromq.org/pipermail/zeromq-dev/attachments/20121229/30d07cb4/attachment.htm 


More information about the zeromq-dev mailing list