[zeromq-dev] [otish] "Why ZeroMQ"
oliver at kfs.org
Tue Jul 27 14:58:19 CEST 2010
On 7/27/2010 4:45 AM, Nicholas Piël wrote:
> I am not really sure about this, wouldn't it be best to name the socket after the role the socket plays?
> For example, in a butterfly example the worker nodes have two types of socket they collect from the upstream and push their info downstream. This clearly shows the unidirectional flow of messages.
Agreed: This is the case highlighted by "REQ"/"REP". The endpoint type
currently named "REQ"uest is the one which receives replies: it is named
for the role of the node and not the function of the socket.
I want to re-suggest the notion of aliases here. Nice, clear,
unambiguous /aliases/ for documentation and introduction purposes.
"ZMQ_SOCKET_THAT_SENDS_REQUESTS_AND_THEN_RECEIVES_RESULTS ('ZMQ_REQ' for
Ok - maybe not that long ;)This is not about requiring paradigm shifts
or better documentation,
>> it's about using consistent names that provide some kind of model the
>> poor developer can depend on.
>> The names Mato and I proposed for the pipeline pattern were:
>> ZMQ_BF_CLIENT, ZMQ_WORKER, ZMQ_COLLECTOR
> I really think these would cause LOTS of troubles. Even in this specifically example you mostly have a server that produces items to be named client.
Agreed, but I think the solution is to name sockets after the role the
socket plays in communicating.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the zeromq-dev