[zeromq-dev] [otish] "Why ZeroMQ"
ph at imatix.com
Tue Jul 27 10:40:20 CEST 2010
On Tue, Jul 27, 2010 at 3:30 AM, Matt Weinstein
<matt_weinstein at yahoo.com> wrote:
> I've been using ZMQ_STREAM_SOURCE and ZMQ_STREAM_SINK.
> There's still that "from which perspective?" problem.
It would be more consistent IMO to always name sockets after the role
that the node plays. Now, request/response are named after the type
of message, publish/subscriber after the role of the node, and
upstream/downstream are perversely named after the role of the
This is not about requiring paradigm shifts or better documentation,
it's about using consistent names that provide some kind of model the
poor developer can depend on.
The names Mato and I proposed for the pipeline pattern were:
ZMQ_BF_CLIENT, ZMQ_WORKER, ZMQ_COLLECTOR
More information about the zeromq-dev