[zeromq-dev] Receiver stopped receiving

Martin Sustrik sustrik at fastmq.com
Thu Oct 22 08:29:15 CEST 2009


It's either a bug or a usage problem. Can you post a simple test program 
to demonstrate the behaviour so that we can have a look at it?


Wong Yam Yip wrote:
> Hi again,
> I have multiple receiver process binding to different sender processes. 
> Each receiver process has multiple receiver objects running on different 
> CWinThreads. Each receiver object is configured to bind to a single 
> sender process. I was trying to test the throughput of this 
> configuration and my experience is that the receiver simplely stops 
> receiving while waiting in the api_thread_t->receive() function. The 
> thing is my threads were still running and I did not receive any error 
> notification from the error_handling(). Wondering how this can happen 
> and how i can avoid this.
> Regards,
> Nic
> ------------------------------------------------------------------------
> New Email names for you! 
> <http://sg.rd.yahoo.com/sg/mail/domainchoice/mail/signature/*http://mail.promotions.yahoo.com/newdomains/sg/> 
> Get the Email name you've always wanted on the new @ymail and @rocketmail.
> Hurry before someone else does!
> ------------------------------------------------------------------------
> _______________________________________________
> zeromq-dev mailing list
> zeromq-dev at lists.zeromq.org
> http://lists.zeromq.org/mailman/listinfo/zeromq-dev

More information about the zeromq-dev mailing list